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About This Book

This manual provides you with information that is needed to install and configure Nways
Manager for Windows NT Version 2.1.

Who Should Read This Book
This manual is intended for the person responsible for installing and configuring Nways
Manager for Windows NT Version 2.1

How To Use This Book
This manual contains the following chapters:

v Chapter 1 ″Introduction ″ describes Nways Manager for Windows NT Version 2.1’s
components and identifies sources for obtaining the hardware and software
requirements for using Nways Manager.

v Chapter 2 ″System Preparation ″ guides you through the steps needed to ensure
that your system meets the necessary requirements for the installation of Nways
Manager for Windows NT Version 2.1.

v Chapter 3 ″Migration ″ explains the steps and important considerations for migrating
to Nways Manager for Windows NT Version 2.1.

v Chapter 4 ″Installing the Products ″ guides you through the installation process of
the applications provided in the Nways Manager-Suite package.

v Chapter 5 ″Post-Installation and Maintenance Procedures ″ describes the steps
necessary to configure and maintain Nways Manager following the installation
process.

v Chapter 6 ″Uninstalling Nways Manager ″ provides the information needed to
uninstall Nways Manager.

Related Publications
The following publications are closely related to or referred to in the Nways Manager
library:

v Nways Remote Monitor for Windows Installation Guide, Part Number 4229492 (This
book also applies to Nways Remote Monitor Version 2.1).

v Nways Manager for Windows NT User’s Guide, SA27–4194

v Nways Remote Monitor for Windows User’s Guide, SA27–4195
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Procedure Checklist
The following checklist is an outline of the necessary steps, in the suggested order, to
successfully complete the installation of the product using the applications shipped in
the package containing Nways Manager-Suite. Use it as a guide as you progress
through the installation steps that are detailed throughout the remainder of this
document.

__ 1. Create and Log in as an Administrative User. (5)

__ 2. Verify all system, hardware, and software environment requirements. (6)

__ 3. Uninstall any IBM antivirus application Version 2.0 or earlier. (10)

__ 4. Close any active applications. (10)

__ 5. If you currently use Nways Workgroup Manager Version 1.x and you are
upgrading, then you will also need to uninstall that application according to the
directions you received with the product. (10)

__ 6. Install SNMP services and Windows NT Service Pack 4 or higher (Service Pack
5 or higher is required for Tivoli NetView IT Director Edition Version 5.1). (11)

__ 7. Install DB2 and apply FixPak 10 (APAR WR21119), if necessary.1 (15)

__ 8. Install updated ODBC drivers.2 (17)

__ 9. Install Tivoli NetView IT Director Edition Version 5.1 or higher (included on a
separate CD), or HP OpenView Network Node Manager 5.02 or higher (not
included). (17)

__ 10. Install Nways Manager Version 2.1. (20)

__ 11. Install Nways Remote Monitor Demonstration Version (Optional). (22)

__ 12. Install Adobe Acrobat Reader (Optional). (22)

__ 13. Install the Configuration Tools (Optional). (23)

__ 14. If you elect to install FixPak 10 from the Nways Manager installation list, it will
automatically install at this point. (24)

__ 15. Install Nways Remote Monitor Version 2.1 Licensed Version (Optional). (24)

__ 16. Extract the JDBC drivers.1 (27)

__ 17. Create a DB2 database for JPM and begin data collection.1 (27)

__ 18. Network Discovery Configuration.2 (29)

These steps are referenced at the beginning of each section, and are explained in more
detail in the remainder of their respective sections. Different sequences of the
installation process may be possible, but the information in this document applies only
to the recommended procedure mapped out herein.

1. For DB2 Universal Database Enterprise Edition Version 5.2 users only.

2. For Tivoli NetView IT Director Edition Version 5.1 users only.
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Chapter 1. Introduction

This chapter provides a brief description of Nways Manager and provides references
and information explaining hardware and software requirements for using Nways
Manager Version 2.1.

Nways Manager consists of the following components:
v Adobe Acrobat Reader, Version 3.01 (needed to view the online books)
v Nways Remote Monitor for Windows NT (Optional)
v Nways Manager, which includes Java-based Distributed Intelligent Agent
v The Enterprise Edition of IBM DB2 Universal Database, Version 5.2, for use only with

Nways Manager for Windows NT, Version 2.1
v Tivoli NetView IT Director Edition Version 5.1, on a separate CD-ROM

For the latest technical information, including prerequisites and supported web
browsers, visit the Nways Management Web site at:

http://www.networking.ibm.com/netmgt

Demonstration Version
Demonstration versions of Nways Manager and Nways Remote Monitor allow you to try
the products free for 60 days. If you are installing the demonstration versions of
these products, then they will become inoperative after 60 days .

Once installed, the demonstration versions can be upgraded to the fully licensed
versions at any time without losing the accumulated data, even after the trial period is
over . For more information, contact your IBM representative.

Important
The following list shows the IBM Nways Manager product offerings and the
components they contain.
Nways Manager CD

Nways Manager for Windows NT

Demonstration version of Nways Remote Monitor for Windows NT

IBM DB2 Universal Database Enterprise Edition Version 5.2, on a
separate CD-ROM

Adobe Acrobat Reader

Tivoli NetView IT Director Edition Version 5.1, on a separate
CD-ROM

Configuration Tools
Nways Remote Monitor CD

Nways Remote Monitor for Windows NT

Demonstration version of Nways Manager for Windows NT

Adobe Acrobat Reader

© Copyright IBM Corp. 1999 1
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About Nways Manager
IBM Nways Manager for Windows NT Version 2.1 is a Simple Network Management
Protocol (SNMP) management platform with a suite of graphical device management
applications that brings integrated, heterogeneous SNMP management to the Microsoft
Windows NT Version 4.0 environment. It works using HP OpenView Network Node
Manager 5.02 or higher, or Tivoli NetView IT Director Edition Version 5.1 or higher as a
platform to provide fault, performance, configuration, accounting, and security
management for SNMP-enabled workstations, hubs, routers, bridges, switches, and
adapters. It provides this information through easy-to-use graphical network and device
displays.

The Java-based management support provided in Nways Manager enables you to
manage your devices from your intranet, the Internet, and from your local NT
workstation. You can use your Java-Soft JDK-1.1.6–enabled Web browser to access the
Nways Manager functions from anywhere in your enterprise.

When you purchase both Nways Manager and Nways Remote Monitor (ReMon), you
will have the added bonus of RMON coupling for most devices that support RMON.
RMON coupling allows the graphical management applications for these devices to
seamlessly access and display the RMON, RMON2, and ECAM data provided for these
devices by Nways Remote Monitor.

For a complete list of supported hardware, please visit our Web site at:

http://www.networking.ibm.com/netmgt

Nways Manager collects network information via Java-enabled Distributed Intelligent
Agents (DIAs). By default, one DIA is installed on the network management station.
When distributed across the network, these agents enable you to offload the polling of
information from the manager workstation, thus freeing up the processor on the
manager. It also places the polling close to the devices being polled, freeing up
bandwidth across WAN links. These agents can be configured to notify Nways Manager
when exceptions (threshold exceeded) occur. The agents can be placed in any
Java-enabled (Java virtual machine) workstations in the network.

One DIA Registered Agent Access is included in the Nways Manager package.
Additional DIAs can be attached only with additional Registered Agent Accesses, which
are available in quantities of 1 (part number: 4300381), 5 (part number: 4300382), and
10, (part number: 4300383). Contact your IBM representative, IBM business partner, or
the IBM North America Sales Centers at 1-800-IBM-CALL, Reference: SE001, to
purchase these items.

Performance management of these devices also requires a Java Database Connectivity
(JDBC)-compliant database to store the performance information. The Enterprise
Edition of the IBM DB2 Universal Database Version 5.2, which is JDBC-compliant, is
provided with Nways Manager on a separate CD-ROM. You may use this copy of
DB2 only in association with your licensed use of IBM Nways Manager for
Windows NT.

2 Nways Manager for Windows NT Installation Guide
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Hardware and Software Requirements
Nways Manager for Windows NT Version 2.1 requires either HP OpenView Network
Node Manager 5.02 or higher, or Tivoli NetView IT Director Edition Version 5.1 or
higher, which serves as its platform.

Note: If you are using HP OpenView Network Node Manager 5.02 or higher, then you
will need to install all patches that are currently available at the HP OpenView
Web site prior to installing Nways Manager Version 2.1.

If neither of these is installed on your machine, then you can install the included CD of
Tivoli NetView IT Director Edition Version 5.1 for use with this program.

For a complete list of hardware and software requirements, see “Verifying
Requirements” on page 6. For any updates to the requirements since this publication,
please visit our Web site at:

http://www.networking.ibm.com/netmgt

Chapter 1. Introduction 3
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Chapter 2. System Preparation

This chapter guides you through the preliminary tasks necessary to verify that your
system meets the minimum requirements and is prepared for the installation of Nways
Manager for Windows NT Version 2.1.

Creating an Administrative User

Reference to Checklist: This section corresponds to list item 1 on page vi.

Note
If there is already a user created with administrative privileges, then verify the
criteria listed in the “Username Guidelines” in step 4 below, enable that user to
act as part of the operating system, and move to “Verifying Requirements” on
page 6.

In order to create a user with Administrator privileges:

1. From the Windows NT desktop, click Start -> Programs -> Administrative Tools
-> User Manager .

2. Select the User menu from the menu bar.

3. Select New User.

4. Enter a username, password, and password confirmation.

If you will be using the DB2 Database, then you must follow this criteria for your
username:

v It must begin with A-Z, @, #, or $ characters.

v It must be 1–8 characters in length.

v It cannot be the following: ADMINS, GUESTS, LOCAL, PUBLIC, or USERS.

v It cannot begin with the following character combinations: IBM, SQL, or SYS.

v It cannot include accented characters.

Windows NT is not case sensitive.

5. Check the appropriate password option.

6. Click Groups .

7. Select Administrators in the list box.

8. Click Add to add the username to the list.

9. Click OK twice to complete the process.

To enable a username to act as part of the operating system, follow these steps:

1. Click Start -> Programs -> Administrative Tools -> User Manager (if not open
from the previous sequence).

2. Select the Policies menu.
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3. Select User Rights.

4. Select the Show Advanced User Rights checkbox.

5. Select the Right drop-down menu button near the top of the dialog box.

6. Select Act as Part of the Operating System from the list.

7. Click Add .

8. Click Show Users .

9. Select the username to add from the list of names. Click Search if you do not see
the name.

10. Click Add .

11. Click OK twice.

12. Close the User Manager window by clicking the X in the upper-right corner.

At this time, you must log out of Windows NT, and log back in as the username that
you have just created.

Verifying Requirements

Reference to Checklist: This section corresponds to list item 2 on page vi.

This section contains instructions explaining how to verify that your system has the
required hardware and software needed to install and use Nways Manager. When you
start the installation of Nways Manager, the installation program will automatically
recheck your system requirements and indicate the areas which may need attention.
The procedures for obtaining some of the possible missing components can be found in
this section.

System
From the desktop, select Start -> Programs -> Administrative Tools -> Windows NT
Diagnostics .
Operating System

1. To verify that your operating system is compatible, select the Version tab.

2. Verify that you have Windows NT Version 4.0 and Service Pack 4 or higher
(Tivoli NetView IT Director Edition Version 5.1 users will need Service Pack
5).

Processor

1. Click the System tab.

2. Verify that your processor is a minimum of a Pentium II, 300 MHz or AMD
K-29.

Display

1. Select the Display tab.

2. Verify that the numbers displayed on the Setting: line are 1024x768x256 or
higher resolution.

CD-ROM

1. Select the Drives tab.
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2. Verify that there is a CD-ROM drive listed and note the letter assigned to
the drive.

Free Disk Space

1. While you still have the Drives tab selected, Click on the ″+″ next to the
Local hard drives listing.

2. Double click on the letter of the hard drive on which you will install Nways
Manager.

3. Select the File System tab to determine what type of file partition system
your unit uses.

4. Select the General tab to view the amount of free disk space.

5. Verify in the Disk Space section that at least:

v 405 MB (424,673,280 bytes) are available if you are using a New
Technology File System (NTFS) disk partition

or

v 2 GB (2,147,483,648 bytes) are available when you are using a File
Allocation Table (FAT) partition

6. Click OK to close the c:\Properties dialog, where c is the drive in which you
will be installing Nways Manager.

RAM

1. Select the Memory tab.

2. Verify in the Physical Memory section that at least 256 MB (384 MB is
recommended) is the minimum RAM space available.

Paging Space

1. Verify the Paging Space, also found when the Memory tab is selected.

2. In the Pagefile Space section, there should be a minimum of 200 MB of
Total Paging space.

Click OK to close the Windows NT Diagnostics Window.
Web Browser

1. Open the browser application that you would like to use with Nways
Manager.

2. Click on the Help menu and select the About... item.

3. Verify that the browser is either Navigator 4.05 or higher, or Internet
Explorer 4.0 or higher.

4. Close the browser window.
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DB2 and FixPak 10

Reference to Checklist: This section also corresponds to step 2 on page vi.

Note
This section only applies if you believe that DB2 Universal Database Enterprise
Edition Version 5.2 is already installed on your machine and you elect to use this
as your database for Nways Manager. If this is not the case, continue with “IP
Address”.

To verify that DB2 and the required FixPak 10 are properly installed on your system:

1. Select Start -> Programs -> MS-DOS Prompt .

2. Type regedit, and the Registry Editor window will open.

3. Expand HKEY_LOCAL_MACHINE -> SOFTWARE -> IBM -> DB2 -> DB2 Universal
Database Enterprise Edition. If DB2 is not listed, then it is not installed.

4. Click on the Current Version folder.

5. Verify the following lines in the right panel:

Version 0x00000005 (5)

Release 0x00000002 (2)

Modification 0x00000000 (0)

Service Level WR21119

If the Service Level does not match, then FixPak 10 is not installed.

6. Close the Registry Editor window.

If DB2, or the required FixPak 10 is not installed, then you will need to install it when
you reach the proper step in this document. The automatic installation feature of FixPak
10 takes place at step 14 on page vi. The download method of installing FixPak 10
should be performed during step 7 on page vi. The automatic installation instructions
can be found in “Installing DB2 FixPak 10 (Automatic)” on page 24, while the download
method is explained in “Installing DB2 Universal Database Enterprise Edition Version
5.2” on page 15.

IP Address

Reference to Checklist: This section also corresponds to step 2 on page vi.

Due to the differences in Tivoli NetView IT Director Edition Version 5.1 or higher and HP
OpenView Network Node Manager 5.02 or higher platforms, there are two sections.
Read the section which applies to the platform you have installed or are planning to
install and use with Nways Manager.

Tivoli NetView IT Director Edition Version 5.1 Users
Tivoli NetView IT Director Edition Version 5.1 does not currently support Dynamic Host
Configuration Protocol (DHCP). DHCP enables you to obtain a temporary IP address
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from a DHCP server when you connect. This means you are required to obtain a fixed
IP address prior to continuing with the installation. If you are not sure if you have a
fixed IP address, follow these steps:

1. Click Start -> Settings -> Control Panel .

2. Double click the Network icon on the desktop.

3. Select the Protocols tab.

4. Select TCP/IP Protocol from the list.

5. Click Properties .

6. Verify that the Specify an IP address radio button is selected and all IP information
is filled in. The Obtain an IP address from a DHCP server radio button should not
be selected.

HP OpenView Network Node Manager 5.02 or Higher Users
HP OpenView Network Node Manager 5.02 or higher supports either static IP
addresses, or Dynamic Host Configuration Prototol (DHCP) addresses. A static IP
address is assigned to your device exclusively, and is the same every time you connect
with that device. DHCP enables you to obtain an IP address from a DHCP server when
you connect, and it does not remain constant. To determine if you have a fixed IP
address, follow these steps:

1. Click Start -> Setting -> Control Panel .

2. Double click the Network icon on the desktop.

3. Select the Protocols tab.

4. Select TCP/IP Protocol from the list.

5. Click Properties .

6. Verify that the Specify an IP address radio button is selected and all IP information
is filled in. The Obtain an IP address from a DHCP server radio button should not
be selected.

If the settings above indicate that you have a static IP address and you will be installing
DB2 to use as your database for Nways Manager Version 2.1, continue with “DB2 and
FixPak 10” on page 8. The remainder of this section explains important configuration
information if you will be using DHCP with HP OpenView Network Node Manager.

Java communications uses the IP host name and not the IP address, therefore both the
client and server need the correct host names to which they are communicating. If the
client is assigned an IP address dynamically, then you need to ensure that this IP
address is associated with the client’s IP host name. This process works correctly with
HP OpenView Network Node Manager 5.02 or higher using Dynamic Host Configuration
Protocol (DHCP).

If your client uses the PPP protocol to connect to the server, then the client will be
dynamically assigned both an IP address and an IP host name. In this situation,
Windows NT clients do not provide the correct IP host name to the Java applications
running in the client. Hence, the Java-based applications will not provide the correct IP
host name to the server, and the server will be unable to send asynchronous
(unsolicited) events to the client. To correct this problem, change the IP host name on
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the client to the value ″localhost″ for the PPP connection’s TCP/IP protocol. The Java
code in the Windows NT client will then provide the server with the correct (dynamically
assigned) IP host name.

To change your host’s name to ″localhost″ for the TCP/IP protocol, perform the
following steps:

1. Select the Network Neighborhood icon on your desktop and click with the right
mouse button.

2. In the popup menu that appears, select Properties at the bottom of the list.

3. Select the Protocols tab that appears at the top of the dialog.

4. Select the TCP/IP protocol in the list that is displayed, and click on the Properties...
button at the bottom of the list.

5. Click on the DNS tab at the top of the next dialog that appears.

6. In the text entry field labeled ″Host:,″ enter "localhost" (without quotes, all
lowercase, with no spaces) as the new name of your machine.

7. Click on the OK button at the bottom of the two dialogs, and reboot the machine
when instructed to do so.

Note that changing your host name in this manner will not modify the name of the
computer in the Identification section of the Network Neighborhood properties, and will
not change the name of the computer across dedicated LAN connections.

Important
These items pertain to steps 3 through 5 on page vi.

v Versions 2 and earlier of the IBM AntiVirus for Windows NT application are
incompatible with this installation program. These versions of IBM AntiVirus
must be uninstalled before installing Nways Manager. After installation
completes, you can reinstall IBM AntiVirus and activate it. Deactivating these
versions of IBM AntiVirus is not sufficient; you must uninstall them. If you
do not remove IBM AntiVirus, the installation program does not create any
product icons or folders in the Windows NT Start Menu.

v Shut down all Windows NT applications before installing Nways Manager. If
any application is running that uses the contents or the existence of any file
that is used during the install process, the installation may fail. If you
experience problems when the installation attempts to create product icons,
ensure that you do not have any antivirus applications installed.

v Any previous versions of Nways Workgroup Manager or Nways Manager for
Windows must be uninstalled at this time according to the instructions provided
in that application’s documentation.
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SNMP and Service Pack 4 or Higher
If these services are not currently installed on your system, continue preparing your
system by following the instructions to install them.

Installing SNMP Services

Reference to Checklist: This section corresponds to step 6 on page vi.

Note
If SNMP services are already installed on your machine, then you should continue
with “Installing Windows Service Pack 4 or Higher”.

To install SNMP Services, follow this procedure:

1. Select Start -> Settings -> Control Panel .

2. Double click on the Network icon.

3. Select the Services tab.

4. Click Add .

5. Select SNMP Service.

6. Insert the Windows NT CD. Stop the process that automatically starts if autorun is
enabled.

7. Click OK.

8. Type e:\i386\ in the edit field, where e is your CD drive.

9. Click Continue .

10. Enter any necessary information on the Agents, Traps, and Security tabs.

11. Click OK.

12. Click Close .

13. Remove the CD from the drive.

14. Click Yes to restart.

Note: If you have just installed SNMP services on your system, then you must install or
reinstall Windows Service Pack 4 or higher (Tivoli NetView IT Director Edition
Version 5.1 requires a minimum Service Pack level of 5).

Installing Windows Service Pack 4 or Higher

Reference to Checklist: This section also corresponds to step 6 on page vi.

If you will be using Tivoli NetView IT Director Edition Version 5.1 as your platform, you
will need a minimum of Service Pack 5. Service Pack 4 (sufficient to run HP OpenView
Network Node Manager 5.02 or higher) or higher is available either on your Windows
NT CD, or as an executable file available for download at:

http://www.microsoft.com/windows/servicepacks
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Once you have downloaded it, follow these steps to install it:

1. Launch the Service Pack executable file (example: filename.exe).

2. Click the check box labeled Accept License Agreement.

3. Click Install .

4. Click Yes.

5. Click Restart .

6. Click Yes or No (appears after computer has restarted).
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Chapter 3. Migration

This chapter contains information on upgrading to Nways Manager Version 2.1 from a
previous version of Nways Manager products.

Migrating from Nways Workgroup Manager Version 1.x or Nways Manager for
Windows

If you are migrating from Nways Workgroup Manager 1.x or Nways Manager for
Windows, you must uninstall these versions of the program, and install Nways Manager
Version 2.1.

Note!
You will lose any stored configurations you have saved using these versions
when you uninstall them.

Migrating from Nways Manager Version 2.0
Nways Manager Version 2.0 can be upgraded to Version 2.1. Because this upgrade is
not a complete uninstall and install, the installation program will save all user-defined
settings and will require significantly less free disk space than a new install.

When beginning the installation, the installation program will query the registry to detect
Nways Manager Version 2.0. If it finds Version 2.0, it will install the new program in the
same drive and directory as the previous version. If the Version 2.0 program was a fully
licensed version, then the installation will automatically update the license information
and install a fully licensed version of 2.1. To migrate to Nways Manager Version 2.1
from Version 2.0:

1. Insert the Nways Manager for Windows NT Version 2.1 CD into the drive. Do not
stop the process if autorun is enabled. If autorun is disabled, click on Start ->
Run... . Enter e:\setup.exe, where e is the CD drive.

2. Click Next at the Welcome box.

3. The installation program will query the registry and inform you where Nways
Manager Version 2.0 is located, and will install Version 2.1 over it. Click OK.

4. Select which components to install, and click Next .

5. Click Yes at the Program License Agreement dialog box.

6. At this point, the Nways Manager installation program will check your system for
the hardware prerequisites. It will inform you of any prerequisites which need
attention.

Steps 7 through 12 will only appear if you are upgrading from a version 2.0 trial version.
If you are upgrading from a fully licensed version of Nways Manager for Windows NT
Version 2.0, then this information will automatically be transferred from your previous
version.
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7. Select the license you will be installing: Suite, Element Manager, or None (Installs
demonstration versions of all components).

8. Click Next .

9. Enter node count if you are not installing a trial version (enter 9999 if you have a
license for unlimited nodes).

10. Click Next .

11. Click OK when the program reports that the keys were copied successfully.

12. Click OK in the box when it displays, ″License Successfully Enrolled.″

13. Click OK in the next box, which begins the file copying process.

14. When the files finish copying, select Next to run the Config Tool Locator.

15. Select the drives you want the Config Tool Locator to search. Click Start Search ,
or File -> Exit to run it later.

16. When the Config Tool finishes searching, select the desired files and click Refit .

17. Select whether or not to launch the Readme file, and click Finished .
At this point, the other applications which you have selected will be installed. After all
other products install, you will see steps 18 and 19.

18. Select the button to restart the computer.

19. Click Finish .

Migration Note: In order to include the support for devices that are supported for the
first time in Nways Manager Version 2.1, there are two files which are
replaced and may need to be reconfigured. If you changed the
configuration of this file on your previous version, this file will need to
be reconfigured to its previous form following the migration. These
files are:
v nways\bin\nwaysjma.ini
v nways\java\properties\JdmServerProperties.txt
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Chapter 4. Installing the Products

This chapter contains sections describing the steps needed to install the components of
Nways Manager-Suite.

When you install Nways Manager-Suite, Element Manager, or Trial, a demonstration
version of all these products on the CD-ROM is installed, even if you did not purchase
a license for the other programs. Any of those demonstration versions can be upgraded
to the fully licensed version at any time. See “Demonstration Version” on page 1 for
more information.

For the most current installation information available since the printing of this
publication, visit our Web site at:

http://www.networking.ibm.com/netmgt

Installing DB2 Universal Database Enterprise Edition Version 5.2

Reference to Checklist: This section corresponds to step 7 on page vi.

Note
If you have verified that you already have DB2 and FixPak 10 installed on your
system, or will not be using DB2 as your database for Nways Manager Version
2.1, then continue with “Installing the Updated ODBC Drivers” on page 17.

Performance management for the Java-based device managers uses a Java Database
Connectivity (JDBC)-compliant database. For your convenience, the Enterprise Edition
of DB2 Universal Database is provided for use with this program.

Follow these instructions for installing the DB2 database:

1. Insert the DB2 CD. Allow the install to start if autorun is enabled. If autorun is
disabled, click Start -> Run and type e:\setup.exe, where e is the CD drive.

2. Click Next .

3. Select the checkbox for DB2 Universal Database Enterprise Edition.

4. Click Next

5. Select the type of install. Typical is recommended.

6. Choose one of these three options:
v Accept the default
v Browse
v Enter a destination drive for DB2 Install.

7. Click Next .

8. Type in the Administrator’s username that was created at the beginning of the
process, or the Network Management username that meets the criteria listed in
“Creating an Administrative User” on page 5.
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9. Type in the password for that username.

10. Type in the same password again to confirm.

11. Click Next .

12. Click Install to start copying the files.

13. After the files finish copying (approx. 4 minutes), remove the CD from the drive.

14. Click Finish to restart Windows NT.

Installing the FixPak

Reference to Checklist: This section corresponds to step 7 (for manual download
method only).

Note
FixPak 10 must be installed to use DB2 Version 5.2 with Nways Manager for
Windows NT Version 2.1. FixPak 10 is designed to be used with DB2 Version 5.2.
If 5.2 is not the version on your system, then be sure to read the Readme file that
comes zipped with FixPak 10 download.

There are two ways of installing FixPak 10. The first method is an automatic installation
from the Nways Manager CD. Mark the checkbox labeled DB2 FixPak 10 when you
insert the CD to install Nways Manager, and FixPak 10 will automatically install and
update a downlevel version of DB2 Version 5.2. See “Installing DB2 FixPak 10
(Automatic)” on page 24 when you reach that section for more information on that
method.

This section explains how to download and install FixPak 10 manually. Follow these
steps:

1. Download the FixPak from IBM’s Web site:

ftp://ftp.software.ibm.com/ps/products/db2/fixes/english-us/db2ntv5
/FP10_WR21119/

Note: FixPak 10 is transferred as the zip file fixpak10.zip. If you do not have a zip
file extractor, a public domain version of pkunzip is also available for
download at this site.

2. Unzip the downloaded FixPak file.
v Using pkunzip, type: pkunzip -d fixpak10.zip your desired directory at the

MS-DOS prompt.
v The files can be extracted into any directory, the final directory will be

determined later during setup.

3. Close all other applications.

4. Stop DB2 database activity by typing these commands from the MS-DOS Prompt:

db2stop

db2admin stop

5. Change the directory of the prompt to the one where you unzipped the FixPak.
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6. Type setup.exe at the prompt.

7. Click Next .

8. Verify the destination directory and click Next .

9. Select the options you wish to start automatically when the machine is booted.

10. Click Next .

11. Review the settings and click Install .

12. When prompted, click Yes to restart the computer.

13. Click Finish .

Installing the Updated ODBC Drivers
The ODBC drivers are only necessary when using the Tivoli NetView IT Director Edition
Version 5.1.

Reference to Checklist: This section corresponds to step 8 on page vi.

Note
If you are installing HP OpenView Network Node Manager on Windows NT, then
skip to “HP OpenView Network Node Manager 5.02 or Higher” on page 18.

Follow this procedure to install the updated ODBC drivers for use with Tivoli NetView IT
Director Edition Version 5.1:

1. Insert the Tivoli NetView IT Director Edition Version 5.1 CD. Stop the setup that
begins if autorun is enabled.

2. Click Start -> Run... .

3. Type e:\intel\microsoft_updated_odbc_drivers\mdac_typ.exe, where e is the CD
drive.

4. Click OK.

5. Click Yes.

6. Click Continue .

7. Choose either Complete or Custom installation. Complete is recommended.

8. Click OK.

Installing the Platform
The following sections apply to the installation of the platform used to run Nways
Manager. If you plan on installing Tivoli NetView IT Director Edition Version 5.1,
continue with “Tivoli NetView IT Director Edition Version 5.1” on page 18. If you plan on
installing HP OpenView Network Node Manager, skip to “HP OpenView Network Node
Manager 5.02 or Higher” on page 18. If you already have the specific versions of either
of these platforms, skip to “Installing Nways Manager for Windows NT Version 2.1” on
page 20.
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Tivoli NetView IT Director Edition Version 5.1

Reference to Checklist: This section corresponds to step 9 on page vi.

If you are installing Tivoli NetView IT Director Edition Version 5.1, then follow these
steps:

1. Insert the Tivoli NetView IT Director Edition Version 5.1 CD.

2. Click Setup , which will bring up the NetView Setup dialog box.

3. Enter your name.

4. Enter your company’s name.

5. Click Continue .

6. Select the installation drive (c: is the default).

7. Click Continue .

8. Select either the single user or server installation mode.

9. Click Continue .

10. Enter the user password.

11. Confirm the user password by entering it again.

12. Click Continue .

13. Select Local or All based upon the network you would like to detect.

14. Click Continue .

15. Enter up to 6 community names.

16. Click Continue .

17. Click Restart Now .

HP OpenView Network Node Manager 5.02 or Higher

Reference to checklist: This section corresponds to step 9 on page vi.

HP OpenView Network Node Manager is not provided in this package. If you have
purchased this product separately, this section explains how to integrate the installation
process of HP OpenView Network Node Manager 5.02 or higher into Nways Manager’s
installation sequence. HP OpenView Network Node Manager Version 5.02 or higher can
be used with Nways Manager for Windows NT. A list of required patches is provided at
the end of this section, but be aware that the patch numbers and contents may change
periodically. Make sure that you download all of the most current patches. For any
further information or questions about HP OpenView Network Node Manager, see the
specific product documentation.

To install HP OpenView Network Node Manager, follow these instructions:

1. Insert the HP OpenView Network Node Manager 5.02 or higher CD into the drive.
Allow the application to run if autorun is enabled. If autorun is disabled, then type
e:setup.exe at the MS-DOS command prompt, where e is the CD drive.

2. Click Next .

3. Click Yes.
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4. Enter the username that you created at the beginning of the process.

5. Enter your company name.

6. Click Next .

7. In the Confirm New Directory dialog box, click Yes.

8. Select Setup Type (Typical is recommended if you are only interested in managing
the local network. If you will be managing a remote network, then select Custom.
Steps 9-17 apply to the Typical installation.

9. Select whether to install IPX support by clicking Yes or No. This only appears if
IPX is not currently installed.

10. Specify the folder in which to install.

11. Click Next .

12. In the SNMP Configuration dialog box, enter the Community Name for the default
gateway.

13. Click Next .

14. Click Next in the Start Copying Files dialog box.

15. Click OK if the Cannot open input file error message appears. This will be resolved
when the patches are installed.

16. Select whether or not to view the error log.

17. Click Finish .

Important: Following the successful installation of HP OpenView Network Node
Manager, you will need to download and install the following patches
available for the platform from:

http://www.ovweb.external.hp.com/cpe/patches

These patches were current at the time this document was printed, but the
names and numbers change frequently. Be sure to obtain the most current
patches available.
HP OpenView Network Node Manager Version 5.02

v NNM_00131
v NNM_00301

HP OpenView Network Node Manager Version 6.01
v NNM_00309
v NNM_00322
v NNM_00324
v NNM_00341
v NNM_00342
v NNM_00349
v NNM_00378

Chapter 4. Installing the Products 19

http://www.ovweb.external.hp.com/cpe/patches


Installing Nways Manager for Windows NT Version 2.1

Reference to Checklist: This section applies to step 10 on page vi.

Important
You should consider the following points before installing Nways Manager:

v Ensure that the Windows NT user ID you are using meets the requirements
explained in “Creating an Administrative User” on page 5. The install program
will exit if the username does not have Administrator privileges.

v If you have a previous version of Nways Workgroup Manager or Nways
Manager for Windows, it must be removed prior to installing this version.

v You must exit all applications prior to installing Nways Manager Version 2.1.

v See the product Readme file for important notes on installation.

As part of the installation process, you will be asked whether or not you want to install a
licensed product or a trial version of Nways Manager. If you elect to install a trial
version of the product, all Nways Manager components will be installed with a
demonstration license good for 60 days following installation. You can upgrade to a
licensed version of Nways Manager at any time without losing your accumulated data.

If you select a licensed product, you will be prompted to enter your customer number
and license key number, and then the number of nodes for which you have purchased
a license.

The installation program for Nways Manager is highly automated. Pressing the F1 key
when a dialog box requires a selection from you will display appropriate help for that
box. Follow these steps to install Nways Manager for Windows NT Version 2.1:

1. Insert the Nways Manager for Windows NT Version 2.1 CD into the drive. Do not
stop the process if autorun is enabled. If autorun is disabled, click on Start ->
Run... . Enter e:\setup.exe, where e is the CD drive.

2. Click Next when the Welcome box appears.

3. Select the checkbox for the components you would like to install: IBM Nways
Manager for Windows NT, IBM Nways Remote Monitor (Demonstration Version),
Adobe Acrobat Reader, Configuration Tools, and/or FixPak 10.

4. Click Yes to accept the Program License Agreement.

5. Select or confirm the installation drive for the Nways installation (the default drive
is c:\Nways). You can click on Disk Space to see how much disk space is
available on the drive. The installation program will display the required available
space and the space available in your target drive. Verify that the number in the
Space Available field is greater than the number in the Space Required field and
click Next .

At this point, the Nways Manager installation program will assess your system for the
required hardware, software, and settings. It will inform you of any areas which do not
meet the requirements, but will continue with the installation if you click Next . You can
also click Cancel to exit the installation.
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6. Select the radio button for the type of license purchased from these choices:
v Nways Manager-Suite
v Nways Manager-Element Manager
v None (installs demonstration versions of Nways Manager-Suite)

Click Next .
Steps 7-12 only apply when you have selected to install the licensed versions of the
applications.

7. Enter node count and click Next .

8. Enter your Customer Number.

9. Enter your License Key.

10. Click Verify Key .

11. Click OK in each of the two Congratulations dialog boxes.

12. Click OK when the screen displays, ″Files successfully unlocked.″

13. Click Next in the Congratulations box.

14. Click OK when the installation confirms that your license information was
successfully enrolled.

15. The installation program will inform you that the target folder is IBM Nways
Manager.

16. Click OK .
The installation program will now copy the files to your system.

17. Click Next to run the Config Tool Locator.

18. If you want to run the Config Tool Locator now, select the drives on which to run
the Config Tool Locator and click Start Search . If you decide at this point to run it
later, click File -> Exit .

19. Select the displayed tools you would like to refit, and click Refit .

20. Select the box to view the readme file and click Finish .
At this point, the installation program will immediately install the other applications which
you selected to install. After all other products install, you will see steps 21 and 22.

21. Select the button to restart the computer.

22. Click Finish .

The Nways Manager installation program creates a log file of the installation in the
c:\temp directory. The filenames are created as nways xx.log , where xx is a number
increment which increases by one each time the installation is run. If any problems
occurred during the installation, consult the log file with the highest number to
determine a possible cause.
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Installing Nways Remote Monitor for Windows NT (Demonstration Version)

Reference to Checklist: This section corresponds to step 11 on page vi.

Note
Nways Remote Monitor Demonstration Version 2.1 is optional. If you have
purchased a licensed version of Nways Remote Monitor or chose not to install it,
then continue with “Installing Adobe Acrobat Reader”.

If you chose to install the demonstration version of Nways Remote Monitor Version 2.1,
then this installation will take place now. Follow these steps to install the demonstration
version of Nways Remote Monitor Version 2.1:

1. Click Next in the Nways Manager Welcome dialog box.

2. Click Yes to agree to the Program License Agreement.

3. Read the installation message and click Next .

4. Select the desired destination location (the default is c:\Remon).

5. When the files finish copying, select whether or not to launch the Readme.

6. Click Finish .

At this point, the other applications which you have selected will be installed. After all
other products install, you will see steps 21 and 22 on page 21 from the Nways
Manager sequence of installation.

Installing Adobe Acrobat Reader

Reference to Checklist: This section corresponds to step 12 on page vi.

Note
This section applies to those who either need help with the installation of Adobe
Acrobat following the Nways Manager installation sequence, or did not install
Adobe Acrobat when Nways Manager was installed and want to install it now. If
neither of these conditions apply, then continue with “Installing the Configuration
Tools” on page 23.

If you selected Acrobat Reader to be installed with the Nways Manager, then the
process begins immediately following the prior component’s installation at step 5. If this
is an installment of only Acrobat Reader, then follow all of the steps:

1. Insert the Nways Manager for Windows NT Version 2.1 CD in the drive. If autorun
is enabled, it will automatically begin the process. If autorun is disabled, click Start
-> Run... . Enter e:\setup.exe, where e is the CD drive.

2. Click Next in the Welcome dialog box.

3. Select the components to be installed.
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4. Click Next .

5. Click Yes to install Adobe Acrobat Reader.

6. Click Next at the Acrobat Reader Setup box.

7. Click Yes to agree to the software license agreement.

8. Confirm or modify the destination location and click Next (the default is
c:\Acrobat3\Reader).

9. Select whether or not to launch the Readme file and click Finish .

10. Setup is complete. Click OK.

At this point, the other applications which you have selected will be installed. After all
other products install, you will see steps 21 and 22 on page 21 from the Nways
Manager sequence of installation.

Installing the Configuration Tools

Reference to Checklist: This section corresponds to step 13 on page vi.

Note
This section applies to those who either need help with the installation of the
Configuration Tools following the Nways Manager installation sequence, or did not
install the Configuration Tools when Nways Manager was installed, but want to
install them now. If neither of these conditions apply, then continue with “Installing
Nways Remote Monitor for Windows NT (Demonstration Version)” on page 22.

If you selected the Configuration Tools to be installed with the Nways Manager, then the
process begins at step 5. If this is an installment of only the Configuration Tools, follow
all of the steps to install the Configuration Tools provided with Nways Manager-Suite:

1. Insert the Nways Manager Version 2.1 CD into the drive. If autorun is enabled, it will
automatically begin the process. If autorun is disabled, click Start -> Run... . Enter
e:\setup.exe, where e is the CD drive.

2. Click Next in the Welcome dialog box.

3. Select the components to be installed.

4. Click Next .

5. Select the checkbox for the configuration tools to install and click Next .

6. Click Next .

7. Click Next in the Configuration Program Installation dialog box.

8. Click OK. (Steps 6, 7, and 8 will repeat until all selected tools have been installed.

9. When all tools have installed, if you did not select to install FixPak 10 automatically,
you will see steps 21 and 22 on page 21 of the Nways Manager sequence of
installation.
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Installing DB2 FixPak 10 (Automatic)

Reference to Checklist: This section corresponds to step 14 on page vi.

At this point, if you selected to install FixPak 10 automatically, the installation program
will query the registry to locate the DB2 Universal Database Enterprise Edition Version
5.2. If it finds the database, then a box will appear asking you if you want to install
FixPak 10. Click Yes and the program will install now.

If the query does not find the DB2 Universal Database Enterprise Edition Version 5.2,
then you must cancel the FixPak installation by clicking No in the box asking you if you
want to install the FixPak. If you click Yes, then you will receive an error message that
the database is not installed. You must install the database prior to installing the FixPak.

Installing Java-based Distributed Intelligent Agent
The Java-based Distributed Intelligent Agent (DIA) is installed on remote workstations in
your network to reduce the performance impact of performance polling. The DIA code is
contained in the nways\java\dia subdirectory, where nways is the directory where
Nways Manager is installed. Refer to the README.TXT file in that directory for more
information on installing the DIAs on PC and Unix-based workstations on your network.

Installing Nways Remote Monitor for Windows NT (Licensed Version)

Reference to Checklist: This section corresponds to step 15 on page vi.

Note
If you have purchased a licensed version of Nways Remote Monitor Version 2.1,
then you will install that version now. If you will be installing the demonstration
version, then refer to “Installing Nways Remote Monitor for Windows NT
(Demonstration Version)” on page 22 for those instructions. If you choose not to
install Remote Monitor, then continue with “Chapter 5. Post-Installation and
Maintenance Procedures” on page 27.

Follow these steps to install the licensed version of Nways Remote Monitor Version 2.1
from the Remote Monitor CD:

1. Insert Nways Remote Monitor Version 2.1 CD.

2. Click Next in the Nways Manager Welcome dialog box.

3. Click on the Remote Monitor checkbox.

4. Click Next .

5. Click Next in the Nways ReMon Welcome dialog box.

6. Click Yes.

7. Click Next when you are finished with the Important Installation Information dialog
box.
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8. Select the destination location.

9. Click Next .

10. Select whether or not to launch the Readme.

11. Click Finish .

12. Select the button to restart the computer.

13. Click Finish .

For more information on this installation, see Nways Remote Monitor for Windows NT
Version 2.0 Installation Guide, included in this package. The content of this publication
is also applicable to Version 2.1.
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Chapter 5. Post-Installation and Maintenance Procedures

This chapter provides the final steps necessary to configure Nways Manager to function
properly. In addition, it explains how to make adjustments which will allow Nways
Manager to continue to change along with your network.

Extracting the JDBC Drivers

Reference to Checklist: This section corresponds to step 16 on page vi.

Note
This section details the extraction of the JDBC drivers, which must be done after
each update to the DB2 FixPak.

If you are not using DB2 as your database for Nways Manager, but are using
Tivoli NetView IT Director Edition Version 5.1 as your platform, then skip to
“Editing the Seed File” on page 29.

Prior to creating a DB2 Database, the Java DataBase Connectivity (JDBC) drivers must
be unzipped into the Nways Manager java\websvr\code directory (folder). Follow these
steps to extract the drivers:

1. Obtain an unzip program (You can use the pkunzip utility that you downloaded with
the DB2 FixPak).

2. Extract db2java.zip file from the Sqllib\java\ directory into the
Nways\java\websvr\code directory.

Creating a DB2 Database for JPM and Starting Data Collection

Reference to Checklist: This section corresponds to step 17 on page vi.

Important
If you chose not to have DB2 started automatically when the machine is started,
then you will have to issue the db2start command from the MS-DOS command
prompt before creating a database.

After making sure that the JDBC drivers are installed and DB2 is started, follow these
steps to create a database:

1. Select Start -> Programs -> MS-DOS prompt .

2. Change the directory to nways\bin.

3. Run the command db2cmd CreateDatabase.bat -create.
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By default, a database will be created on the same disk that DB2 was installed. It is
advised that this disk partition have at least 60 to 100 MB of free disk space. If you
intend to store historical statistics for more than 20 devices over a period several
weeks or longer, then you will need approximately 1 GB or more of available disk
space.

4. Depending on your platform:
v Start NetView by selecting Start -> Programs -> NetView -> NetView Console .
v Start OpenView by selecting Start -> Programs -> OpenView -> Network Node

Manager .

5. Select Tools -> IBM Nways Java -> Performance Configuration .

6. Click on the Database tab.
If you are using HP OpenView Network Node Manager on Windows NT, then you may
be asked to enter your username and password. If so, enter the administrative
password that you created at the beginning of this process.

7. Click Start Collection .

Potential Problems Connecting to a JDBC-enabled Database
If you encounter problems connecting to the JDBC-enabled database from Nways
Manager, try the following solutions.

Message: Could not find JDBC driver classes. Closing connection.
Action: Install or reinstall the JDBC drivers.

v For DB2, unzip the JDBC drivers (found in Sqllib\java\db2java.zip
where Sqllib is the default directory into which DB2 was installed) into
nways\java\websvr\code, where nways is the directory into which
Nways Manager was installed. You may have to retrieve an unzip
program from the Internet to perform this task.

v For other databases, refer to the documentation for those databases.
The JDBC drivers must exist in the Nways classpath
(nways\java\websvr\code, where nways is the directory into which
Nways Manager was installed) to allow connection to the database.

Message: JDBC connect error. Check database URL and make sure your
username and password are correct. Closing connection.

28 Nways Manager for Windows NT Installation Guide



Action: v Check to make sure your database system and JDBC drivers are
JDBC-compliant. The database must support ANSI-92 SQL.

v Check the JDBC URL and make sure it is the one that the database
manufacturer suggests you use. This can usually be found in the
database documentation under a section dealing with running Java
applications. If you are using a third-party driver, then the URL and
driver name should be included with that driver. the default URL is
given for the DB2 running locally.

v Make sure you have created a database called IBMNMPDB.

– If you are not using DB2, read your database documentation on
how to do this.

– If you are using DB2, change to the directory nways\bin, where
nways is the directory into which Nways Manager was installed,
and run the command: db2cmd CreateDatabase.bat -create

v Make sure that the disk on which you have created the database has
at least 60 to 100MB of space. The exact amount of space required
depends on how much historical information will be stored

v The following databases and JDBC drivers are known to be
incompatible with Nways Manager and are not recommended:

– Microsoft Access, JDBC-ODBC Bridge.

Clearing out the DB2 Database
After a period of use, it may be necessary to clear out the DB2 database. To clean out
the database, change to the directory nways\bin, where nways is the directory into
which Nways Manager was installed, and run the command:
db2cmd�CreateDatabase.bat -create

Editing the Seed File

Reference to Checklist: This section corresponds to step 18 on page vi.

Note
This section only applies if you are using Tivoli NetView IT Director Edition
Version 5.1.

Tivoli NetView IT Director Edition Version 5.1’s default only discovers devices within one
hop of the machine running NetView. In order to discover others, follow these steps to
edit the seed file:

1. Start NetView by selecting Start -> Programs -> NetView -> NetView Console .

2. Select Options -> Discovery... .

3. Select the Discover with Seed File check box.

4. Click Edit .
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5. Add Seed IP address to the bottom of the file (the default seed file contains
instructions).

6. Select File -> Save.

7. Close the Notepad window.

8. Click Edit to the right of the Use Alternative Community Names in File field.

9. Add any additional Community Names to the bottom of the file (the default
community names file contains instructions).

10. Select File -> Save.

11. Close the Notepad window.

12. Change the Discovery Speed field from Medium to High Initially.

13. Click Apply .

14. Click Yes.

15. Click OK.

16. Double click the IP Internet icon in the Root map. Nodes will appear on the map
as they are polled. Blue squares in the Network Polling Activity box indicates that
polling is in progress, while red squares mean that a poll is pending.

To refresh the Nways Device Management map, select Tools -> IBM Nways Java ->
Refresh Nways Map .

Managing Licenses
As part of the installation process, you are asked whether or not you want to install a
licensed product or a trial version of Nways Manager. If you elect to install a trial
version of the product, all Nways Manager components will be installed with a
demonstration license good for 60 days following installation. You can upgrade to a
licensed version of Nways Manager at any time without losing your accumulated data.

If you select a licensed product, you will be prompted to enter your customer number
and license key number, and then the number of nodes for which you have purchased
a license.

Enter this information and click OK to continue the installation.

Upgrading Licenses
To upgrade from the demonstration version to the licensed version of Nways Manager,
you must restart the installation program to install the license.

Note: No new code will be installed and your existing configuration will be preserved.
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Increasing the Number of Licensed Nodes
If you have purchased a license allowing you to manage additional nodes using Nways
Element Manager or Nways Manager Suite, use the following procedure from the
NetView console to update the node-count associated with your product license:

1. Select Tools -> IBM Nways Java -> Open License Status from the NetView menu
bar.

2. Select Update from the License Status panel to invoke the Update panel.

3. Enter the value for the updated number of licensed nodes (enter 9999 if you have a
license for an unlimited number of nodes).

4. Select Update Now to save the new value.

5. Click Close to return to the License Status panel.

6. You can click Refresh at the bottom of the License Status panel to see the updated
values.

Click the Close button to exit the License Status panel.

Determining What Nodes to Monitor
Nways Manager determines what nodes to monitor by the contents of the file
nwaysjma.ini. To remove nodes that you do not want to monitor and thus increase the
number of other nodes you can monitor with your current license, you can edit this file
and remove their entries. To edit the file, access the IBM Nways Manager group and
select Edit nwaysjma.ini.

To add nodes that you do want to monitor, edit the file and create entries for them. To
do this, you must know their System Object Identifier (SYSOID).

A copy of this file is created in the c:nways/bin directory, where c is the target drive of
the installation. The file is created with the installation and is given the filename
original.nwaysjma.ini. To revert to your original configuration, rename this file
nwaysjma.ini.

Accessing Java-based Management Applications from a Web Browser
There are three components involved in Web browser-based access to the Java-based
management applications:

The Nways Manager Workstation
The Nways Manager Workstation maintains the Nways Manager web pages
that are sent from the web server to the web browser clients.

The Web Server
The Web server provides the Nways Manager web pages to the web browser
clients when requested. The web server does not need Java support, it sees
the Nways Manager web pages as data files. It is recommended that the web
server be located on the same workstation as the Nways Manager workstation.

The JDK 1.1.6–compliant Web Browser Client
The web browser client requests the Nways Manager web pages from the
Web servers.
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In order to utilize all the functions of Nways Nways Manager, you will need a
JDK 1.1.6–compliant browser. However, to view the JMA help or the reports
generated by the Java Performance Manager, you can use any web browser.

The Web Server
In order to make the Nways Manager web pages available to the web browser clients,
you will need to associate the Nways Manager web pages with a logical directory name
in your web server. Most web servers allow you to specify the logical directory name
(for example, Nways) using its administration program. The Nways Manager web pages
are located in nways\java\websvr on the Nways Manager, where nways is the directory
in which you installed Nways Manager.

Settings
All Web Servers must be configured to communicate with the client on port 80, which is
the default port in most Servers. The following sections define the required settings for
some common Web Servers.

Apache Web Server: Add the following lines, in this order, to the file
\Server_root\conf\srm.conf:

Alias \nways "\Nways\java\websvr"
Alias \cgi\code "\Nways\java\websvr\code"
ScriptAlias \cgi "\Nways\java\websvr"

Where Server_root is the directory in which Apache Websvr is installed, and Nways is
the directory where the Nways product is installed.

Netscape Web Server:

1. Go to the server main page to verify that the server is on.

2. Select the Programs menu from the menu bar.

3. Select CGI File Type .

4. Select Yes to activate CGI as a file type.

5. Select Content Management from the menu bar.

6. Select Additional Document Directories , and add the following lines:

URL prefix: nways
Map To Directory: \Nways\java\websvr

URL prefix: cgi
Map To Directory: \Nways\java\websvr

Domino Web Server:

1. Go to http://Machine/Frntpage.html, where Machine is the directory in which you
installed the Domino Web Server.

2. Select Configuration and Administration Forms , which will take you to
http://Machine/admin-bin/Cfgin/initial.

3. Select Request Routing , which will take you to http://Machine /admin-
bin/Cfgin/mpfrule.

4. Add the following lines in this order:
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Action Request Template Replacement File Path
------ ---------------- ---------------------
Pass \nways\* \Nways\java\websvr\*
Exec \cgi\CgiLauncher* \Nways\java\websvr\CgiLauncher*
Pass \cgi\* \Nways\java\websvr\*

The JDK 1.1.5-Compliant Web Browser
Java support comes with your browser.

Note: If you are using Microsoft Internet Explorer Version 4.x or 5.x, then you must
update the Java Virtual Machine by selecting other options at the Web site:

http://www.microsoft.com/windows/ie/download/default.asp

You will also need to download the RMI patch from the same site.

For information on configuring your browser for use with Nways Manager, detailed
instructions are contained in the file:
nways\java\websvr\help\ibm.nways.subsys.webtoc.html. Nways is the directory where
Nways Manager is installed.

After configuring your browser, you can access the Java-based management
applications for your devices by specifying the URL for the Nways Manager HTML
pages to the web browser.

Accessing the Java-based Management Application Helps
The Java-based management applications use a Web browser to display their HTML
help panels. The Nways Manager install program will attempt to locate your default
browser by looking in the NT registry. If it finds one it recognizes, it will tell Nways
Manager to use it.

If it cannot locate a browser it recognizes, then it will issue a warning message
requiring you to specify the path in
the nways\java\websvr\properties\BrowserApplet.txt file. Specify the fully qualified
name for the web browser on the ″webBrowser.path=″ line, where nways is the
directory in which Nways Manager is installed.

About Device Configuration Programs
Some IBM networking devices include a configuration program. Nways Manager allows
you to launch these configuration programs from the device’s JMA.

In order to launch the configuration program from the JMA, Nways Manager must know
the location of the configuration tool on the Nways Management Workstation. For
configuration tools shipped after July 1998, this information is added to the program
registry when the configuration tool is installed.

To locate older versions of configuration tools, Nways Manager includes the Config Tool
Locator, which locates existing versions of configuration tools already installed on the
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Nways Management Workstation. You should run the Config Tool Locator when you
install Nways Manager, and again after each installation of a configuration tool that
originally shipped prior to July 1998.

To run the Config Tool Locator from the Start menu, select Programs -> IBM Nways
Manager -> Config Tool Locator .

If the Config Tool Locator is unable to find a configuration tool that is loaded on the
Nways Management workstation, you can add the location of the program to the
registry using the following procedure:

1. Locate the correct configuration tool (cfg.exe or cfg.app file) on the path
nways/java/fixcfg, and note the file size.

2. Check the Config Tool Locator’s FixCfg.properties file to ensure that the file size of
this configuration tool is unique.

3. Add a new entry to the FixCfg.properties file, using existing entries as models.

4. Rerun the Config Tool Locator.

5. Restart the JMA.

Nways Deployment Manager
Nways Deployment Manager is one of the components installed with Nways Manager
for Windows NT. When you initially start Nways Deployment Manager, you will have to
create a DB2 database named CFGMAN. Follow these steps to create the database
and open Nways Deployment Manager for the first time:

1. Click Start -> Settings -> Control Panel .

2. Double click the Services icon.

3. Find and select the DB2 Security Server entry in the Service column.

4. Confirm that the Status is Started. If the Status is not Started, then click the Start
button.

5. In the same entry, confirm that the Startup is Automatic. If the Startup is not
Automatic, then click the Startup... button and change the Startup Type to
Automatic.

6. Click Start -> Programs -> Command Prompt .

7. Type ovstop JMAintegrator.

8. Click Start -> Programs -> DB2 -> Administration Tools -> Control Center .

9. Click Systems -> [your computer name] -> Instances -> DB2 -> Databases .

10. Right click on Databases and select Create -> New.

11. Follow the SmartGuide and create a database named CFGMAN

12. At the Command Prompt, type ovstart JMAintegrator.

13. Launch Nways Deployment Manager by clicking Start -> Programs -> IBM Nways
Manager -> Launch Deployment Manager .

After the initial database creation, you can launch Nways Deployment Manager from the
Tivoli NetView IT Director Edition Version 5.1 main menu, by selecting Tools -> IBM
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Nways Java -> Open Deployment Manager . For more information on this component,
see the Nways Deployment Manager User’s Guide.
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Chapter 6. Uninstalling Nways Manager

This chapter describes how to uninstall the application and describes special
considerations for reinstalling the application.

Removing Nways Manager
You can uninstall Nways Manager for Windows NT by selecting the Add-Remove
Programs icon on the Windows NT Control Panel. The Add/Remove Programs
Properties dialog includes a list of the applications installed on your system. Select IBM
Nways Manager and click Add/Remove... to remove the application from your system.

The uninstallation process will remove all files that were created during the install. It will
also undo all registry changes and changes made to files of type .ini during the install.
It will neither remove files that were created during the execution of the program, nor
will it remove the full product directory tree.

After the uninstallation completes, you will need to perform the following steps to fully
remove the application data files and directories:

1. Refer to the Nways Manager README file for additional instructions required to
completely remove Nways Manager from your system

2. Execute the configuration program for your Web Server application. Remove the
nways\java\websvr directory from the list of directories.

3. Delete the nways directory.

4. Update the Path settings in the Environment Variables:

a. Click Start -> Settings -> Control Panel .

b. Double-click the System icon.

c. Select the Environment tab.

d. Scroll through the System Variables field until you find Path.

e. Select the Path entry.

f. Find the path entries c:\Nways\bin; and c:\Nways\lib;, where c is the drive
where Nways Manager was installed.

g. Select these sections and use the Delete key to remove them from the path
(Important: Do not click the Delete pushbutton, as you will delete the
entire path !).

h. Click Set.

i. Click OK.

Nways Manager for Windows NT is now fully removed from your system.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A. IBM
may not offer the products, services, or features discussed in this document in other
countries. Consult your local IBM representative for information on the products and
services currently available in your area.

References in this publication to IBM products, programs, and services do not imply
that IBM intends to make these available in all countries in which IBM operates. Any
reference to an IBM product, program, or service is not that only IBM’s product,
program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any of IBM’s intellectual property rights may be used
instead of the IBM product, program, or service. Evaluation and verification of operation
in conjunction with other products, except those expressly designated by IBM, are the
user’s responsibility.

IBM may have patents or pending patent applications covering the subject matter in this
document. The furnishing of this document does not give you any license to these
patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other country
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS
MACHINES CORPORATION PROVIDES THIS PUBLICATION ″AS IS″ WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. Some states do
not allow disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes
are periodically made to the information herein; these changes will be incorporated in
new editions of the publication. IBM may make improvements and/or changes in the
product(s) and/or program(s) described in this publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for convenience
only and do not in any manner serve as an endorsement of those Web sites. The
materials at those Web sites are not part of the materials for this IBM product and use
of those Web sites is at your own risk.

Trademarks
The following terms are trademarks of the IBM Corporation in the United States or other
countries or both:

Nways Etherstreamer Netfinity
DB2 IBM LANStreamer
DB2 Universal Database

Java and HotJava, and the Java Logo are trademarks of Sun Microsystems, Inc.

Microsoft, Windows, Windows NT, and the Windows 95 and Windows 98 logos are
trademarks or registered trademarks of Microsoft Corporation.

Pentium® is a registered trademark of Intel Corporation in the U.S and other countries.

Navigator is a trademark of Netscape Communications Corporation.

Adobe Acrobat Reader is a registered trademark of Adobe Systems, Inc.

Other company, product, and service names may be trademarks or service marks of
others.
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